It is currently Thu Nov 23, 2017 2:29 pm




Reply to topic  [ 3 posts ] 
 Subaru dying mid run.  
Author Message
New Member

Joined: Tue Sep 19, 2017 3:16 pm
Posts: 2
Post Subaru dying mid run.
I have a Subaru EH72fi that fires right up and idles like a dream, but I have had the engine shut off during a WOT run and would not start back up and also would not start up after a long run. After the motor cools down to room temp it will fire back up no problem.

Any help or ideas would be great, I'm a new owner to this boat/motor. Thanks


Sent from my iPhone using Tapatalk


Sat Oct 07, 2017 1:28 pm
Profile
MMT Pro Member

Joined: Wed Nov 24, 2010 5:07 am
Posts: 275
Location: Miramar Fl
Post Re: Subaru dying mid run.
Vapor lock, or a bad quick connection. See if it keeps running at WOT as you pump the bulb and there's your answer


Sun Nov 05, 2017 12:43 am
Profile
MMT Member

Joined: Mon Dec 16, 2013 6:37 pm
Posts: 24
Post Re: Subaru dying mid run.
Mine would do the same thing. It turned out to be my temperature sensor wire was broken where it screws to the block. Looking from the back of the motor, its a black wire with a terminal loop that is screwed to the block.


Tue Nov 14, 2017 3:56 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: SCThax and 61 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to: